AS7 Logging: System Logging produced incorrect information

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

AS7 Logging: System Logging produced incorrect information

Bill Hong (Gong)

Hi,

 

I’ve been testing AS7 logging system for our product. I got strange logging information after the web application was deployed. The web application loaded  Spring context when application was started up. It seemed system could not produce correct logging information once the Spring context of web application was loaded. Something was wrong after that.

 

It created information like:

<Aug 22, 2011 4:53:43 PM> <INFO> <org.jboss.as.server.deployment.DeploymentHandlerUtil$4 execute> <Replaced deployment "%s" with deployment "%s">

 

In standalone.xml, it defined pattern like “%d{HH:mm:ss,SSS} %-5p [%c %M] (%t) %s%E%n”. As you know, there were two problems in the logging information:

1) %t was not replaced by correct thread information

2) %s%E%n was not replaced by relevant information.

 

I’m not sure if anyone has reported similar issue already. Is there anything I can do for further investigation and find a workaround?

 

Thank you!

 

Regards,

Bill



CONFIDENTIALITY NOTICE
This e-mail message from Delphi Technology, Inc. is intended only for the individual or entity to which it is addressed. This e-mail may contain information that is privileged, confidential and exempt from disclosure under applicable law. If you are not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you received this e-mail by accident, please notify the sender immediately and destroy this e-mail and all copies of it.

_______________________________________________
jboss-as7-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/jboss-as7-dev