Jira components for MicroProfile

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Jira components for MicroProfile

Radoslav Husar
Hello Jira admins whoever you are,

Out current Jira components for MicroProfile are a bit messy [1].

1) We are missing MicroProfile Jira components for OpenAPI, Fault
Tolerance, JWT, etc. These need to be added with corresponding owners.
2) The existing components are unnecessarily abbreviated, please
rename "MP Config" and alike to "MicroProfile Config" to make them
easier to find.
3) The existing component descriptions are a bit mangled, e.g.
"MIcroprofile" or "Microprofile".
4) Do we need a "catchall" MicroProfile component for issues not
specific to any spec, e.g. [2], [3]?

Thanks!

Rado

PS: As always, I am happy to do it if given admin access ;-)

[1] https://issues.jboss.org/projects/WFLY?selectedItem=com.atlassian.jira.jira-projects-plugin:components-page

[2] https://issues.jboss.org/browse/WFLY-12757

[3] https://issues.jboss.org/browse/WFLY-12681
_______________________________________________
wildfly-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/wildfly-dev
Reply | Threaded
Open this post in threaded view
|

Re: Jira components for MicroProfile

Darran Lofthouse
Not sure if we need a MicroProfile JWT component, it is just another aspect of security maintained by the same team.

On Tue, Nov 5, 2019 at 4:48 PM Radoslav Husar <[hidden email]> wrote:
Hello Jira admins whoever you are,

Out current Jira components for MicroProfile are a bit messy [1].

1) We are missing MicroProfile Jira components for OpenAPI, Fault
Tolerance, JWT, etc. These need to be added with corresponding owners.
2) The existing components are unnecessarily abbreviated, please
rename "MP Config" and alike to "MicroProfile Config" to make them
easier to find.
3) The existing component descriptions are a bit mangled, e.g.
"MIcroprofile" or "Microprofile".
4) Do we need a "catchall" MicroProfile component for issues not
specific to any spec, e.g. [2], [3]?

Thanks!

Rado

PS: As always, I am happy to do it if given admin access ;-)

[1] https://issues.jboss.org/projects/WFLY?selectedItem=com.atlassian.jira.jira-projects-plugin:components-page

[2] https://issues.jboss.org/browse/WFLY-12757

[3] https://issues.jboss.org/browse/WFLY-12681
_______________________________________________
wildfly-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/wildfly-dev

_______________________________________________
wildfly-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/wildfly-dev
Reply | Threaded
Open this post in threaded view
|

Re: Jira components for MicroProfile

Brian Stansberry
Right now I'll add MP OpenAPI and MP Fault Tolerance and I'll clean up the caps in the descriptions..

If the consensus on the thread, with Darran getting a big vote, is that we need MP JWT then I'll add it.

For now to be consistent I'll call them MP. I have no problem changing them to use MicroProfile, but I'll let this thread discuss a bit longer on where to put the furniture before I start moving it around. ;)

Re: a generic MicroProfile component, personally I find that kind of thing confusing.  General purpose components become a crack where things get lost, or at least slowed done waiting for someone to notice them and reassign. We already have the 'Server' general bucket. I know there are some general tasks we'll be dealing with over the next few quarters, but I wonder for how long that will be a common thing. You can't later remove a component without first removing it from all issues.

On Tue, Nov 5, 2019 at 10:56 AM Darran Lofthouse <[hidden email]> wrote:
Not sure if we need a MicroProfile JWT component, it is just another aspect of security maintained by the same team.

On Tue, Nov 5, 2019 at 4:48 PM Radoslav Husar <[hidden email]> wrote:
Hello Jira admins whoever you are,

Out current Jira components for MicroProfile are a bit messy [1].

1) We are missing MicroProfile Jira components for OpenAPI, Fault
Tolerance, JWT, etc. These need to be added with corresponding owners.
2) The existing components are unnecessarily abbreviated, please
rename "MP Config" and alike to "MicroProfile Config" to make them
easier to find.
3) The existing component descriptions are a bit mangled, e.g.
"MIcroprofile" or "Microprofile".
4) Do we need a "catchall" MicroProfile component for issues not
specific to any spec, e.g. [2], [3]?

Thanks!

Rado

PS: As always, I am happy to do it if given admin access ;-)

[1] https://issues.jboss.org/projects/WFLY?selectedItem=com.atlassian.jira.jira-projects-plugin:components-page

[2] https://issues.jboss.org/browse/WFLY-12757

[3] https://issues.jboss.org/browse/WFLY-12681
_______________________________________________
wildfly-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/wildfly-dev


--
Brian Stansberry
Manager, Senior Principal Software Engineer
Red Hat

_______________________________________________
wildfly-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/wildfly-dev
Reply | Threaded
Open this post in threaded view
|

Re: Jira components for MicroProfile

Brian Stansberry


On Tue, Nov 5, 2019 at 11:19 AM Brian Stansberry <[hidden email]> wrote:
Right now I'll add MP OpenAPI and MP Fault Tolerance and I'll clean up the caps in the descriptions..

If the consensus on the thread, with Darran getting a big vote, is that we need MP JWT then I'll add it.

For now to be consistent I'll call them MP. I have no problem changing them to use MicroProfile, but I'll let this thread discuss a bit longer on where to put the furniture before I start moving it around. ;)

I'm curious what the issue with 'MP' is. This has come up in a different context from this one so I'm curious about the reasoning; e.g. if there's a general desire in the MicroProfile community not to abbreviate, or perhaps 'MP' is bad in some cultural contexts, or perhaps it's too overloaded.

Re: a generic MicroProfile component, personally I find that kind of thing confusing.  General purpose components become a crack where things get lost, or at least slowed done waiting for someone to notice them and reassign. We already have the 'Server' general bucket. I know there are some general tasks we'll be dealing with over the next few quarters, but I wonder for how long that will be a common thing. You can't later remove a component without first removing it from all issues.

On Tue, Nov 5, 2019 at 10:56 AM Darran Lofthouse <[hidden email]> wrote:
Not sure if we need a MicroProfile JWT component, it is just another aspect of security maintained by the same team.

On Tue, Nov 5, 2019 at 4:48 PM Radoslav Husar <[hidden email]> wrote:
Hello Jira admins whoever you are,

Out current Jira components for MicroProfile are a bit messy [1].

1) We are missing MicroProfile Jira components for OpenAPI, Fault
Tolerance, JWT, etc. These need to be added with corresponding owners.
2) The existing components are unnecessarily abbreviated, please
rename "MP Config" and alike to "MicroProfile Config" to make them
easier to find.
3) The existing component descriptions are a bit mangled, e.g.
"MIcroprofile" or "Microprofile".
4) Do we need a "catchall" MicroProfile component for issues not
specific to any spec, e.g. [2], [3]?

Thanks!

Rado

PS: As always, I am happy to do it if given admin access ;-)

[1] https://issues.jboss.org/projects/WFLY?selectedItem=com.atlassian.jira.jira-projects-plugin:components-page

[2] https://issues.jboss.org/browse/WFLY-12757

[3] https://issues.jboss.org/browse/WFLY-12681
_______________________________________________
wildfly-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/wildfly-dev


--
Brian Stansberry
Manager, Senior Principal Software Engineer
Red Hat


--
Brian Stansberry
Manager, Senior Principal Software Engineer
Red Hat

_______________________________________________
wildfly-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/wildfly-dev
Reply | Threaded
Open this post in threaded view
|

Re: Jira components for MicroProfile

Darran Lofthouse
The MicroProfile JWT authentication mechanism is called "MP-JWT" - there was no reason it must be kept below a certain length so "MP" is used in some contexts.

On Wed, Nov 6, 2019 at 4:50 PM Brian Stansberry <[hidden email]> wrote:


On Tue, Nov 5, 2019 at 11:19 AM Brian Stansberry <[hidden email]> wrote:
Right now I'll add MP OpenAPI and MP Fault Tolerance and I'll clean up the caps in the descriptions..

If the consensus on the thread, with Darran getting a big vote, is that we need MP JWT then I'll add it.

For now to be consistent I'll call them MP. I have no problem changing them to use MicroProfile, but I'll let this thread discuss a bit longer on where to put the furniture before I start moving it around. ;)

I'm curious what the issue with 'MP' is. This has come up in a different context from this one so I'm curious about the reasoning; e.g. if there's a general desire in the MicroProfile community not to abbreviate, or perhaps 'MP' is bad in some cultural contexts, or perhaps it's too overloaded.

Re: a generic MicroProfile component, personally I find that kind of thing confusing.  General purpose components become a crack where things get lost, or at least slowed done waiting for someone to notice them and reassign. We already have the 'Server' general bucket. I know there are some general tasks we'll be dealing with over the next few quarters, but I wonder for how long that will be a common thing. You can't later remove a component without first removing it from all issues.

On Tue, Nov 5, 2019 at 10:56 AM Darran Lofthouse <[hidden email]> wrote:
Not sure if we need a MicroProfile JWT component, it is just another aspect of security maintained by the same team.

On Tue, Nov 5, 2019 at 4:48 PM Radoslav Husar <[hidden email]> wrote:
Hello Jira admins whoever you are,

Out current Jira components for MicroProfile are a bit messy [1].

1) We are missing MicroProfile Jira components for OpenAPI, Fault
Tolerance, JWT, etc. These need to be added with corresponding owners.
2) The existing components are unnecessarily abbreviated, please
rename "MP Config" and alike to "MicroProfile Config" to make them
easier to find.
3) The existing component descriptions are a bit mangled, e.g.
"MIcroprofile" or "Microprofile".
4) Do we need a "catchall" MicroProfile component for issues not
specific to any spec, e.g. [2], [3]?

Thanks!

Rado

PS: As always, I am happy to do it if given admin access ;-)

[1] https://issues.jboss.org/projects/WFLY?selectedItem=com.atlassian.jira.jira-projects-plugin:components-page

[2] https://issues.jboss.org/browse/WFLY-12757

[3] https://issues.jboss.org/browse/WFLY-12681
_______________________________________________
wildfly-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/wildfly-dev


--
Brian Stansberry
Manager, Senior Principal Software Engineer
Red Hat


--
Brian Stansberry
Manager, Senior Principal Software Engineer
Red Hat

_______________________________________________
wildfly-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/wildfly-dev