Rename of JIRA "Domain Management" component to "Management"
FYI, I've renamed the "Domain Management" component to simply "Management" in the WFLY and WFCORE JIRA projects. The old name was misleading as it implied the component is about domain mode, which has never been true. Probably less than a quarter of work in the component over the years has been about domain mode, and that percentage is decreasing as we focus more on cloud use cases.
This has been on my todo list for years now and I'm cleaning off my desk a bit. :)
In case it's helpful, here's what's covered by this component:
1) The functionality associated with all the WildFly 'kernel' management resources, i.e. the many resources that are not part of an extension/subsystem.
2) The Extension API that subsystem authors code against, including the many helper/base classes they can use.
3) The server boot and shutdown logic. (This could be considered 'Server' component but in practice it's easier to lump this in with Management.)
4) The basic management client API and the support code for JBoss Remoting-based remote communication from a client.
5) Domain mode.
Management-related things that are not in this component but which should be tracked via other component:
A) Client-side issues with the CLI: use the CLI component. (OTOH just because you used the CLI to produce an issue on the server doesn't mean it's a CLI issue.)
B) Client-side issues with the web console: use the Web Console component.
C) JMX issues: use the JMX component.
D) Management issues for a particular subsystem: use the subsystem's JIRA component. If you think there may be a general issue, add Management as well, but don't skip the subsystem's component.