X/Post from User List: After upgrading to JSF 2.3 - WildFly 13 Java EE 8 preview mode, iOS and Mac OSX fails to load HTTPS site getting UT005085 errors.

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

X/Post from User List: After upgrading to JSF 2.3 - WildFly 13 Java EE 8 preview mode, iOS and Mac OSX fails to load HTTPS site getting UT005085 errors.

George Labuschagne

Good day all

 

I hope this is not frowned upon; if it is, sincerest apologies.

 

I posted to the users list but perhaps there is a better chance getting an answer from the development list?

 

Below is a copy and paste of the user list email chain so far:

 

 

 

Good day

 

According to this SO question’s comments:

 

https://stackoverflow.com/questions/51484592/site-rendering-broken-on-mobile-after-moving-to-jdk-10-and-jsf-2-3

 

and this error for Payara:

 

https://github.com/payara/Payara/issues/2625

 

It seems to be a problem that has to do with HTTP/2 PUSH

 

So why is this only effecting iOS and Mac OSX? And any suggestions on how to resolve this issue?

 

Kind regards,

 

George

 

 

From: [hidden email] <[hidden email]> On Behalf Of George Labuschagne
Sent: Monday, 30 July 2018 11:29
To: 'The JBoss User main mailing list' <[hidden email]>
Subject: Re: [jboss-user] After upgrading to JSF 2.3 - WildFly 13 Java EE 8 preview mode, iOS and Mac OSX fails to load HTTPS site getting UT005085 errors.

 

Good day

 

I was able to get onto the local LAN with my phone and connected to a normal HTTP session from my iPhone. Works 100%, fast, beautifully rendered with no warnings or error in any logs.

 

Kind regards,

 

George

 

From: [hidden email] <[hidden email]> On Behalf Of George Labuschagne
Sent: Monday, 30 July 2018 11:02
To: [hidden email]
Subject: [jboss-user] After upgrading to JSF 2.3 - WildFly 13 Java EE 8 preview mode, iOS and Mac OSX fails to load HTTPS site getting UT005085 errors.

 

Good day

 

We are using WildFly 13 in Java EE 8 preview mode with TLS enabled for HTTPS

 

However, since updating the POM file (contents included below) and a few places in the code itself, we are able to run JSF 2.3.5.SP1 with PrimeFaces 6.2.7 and OmniFaces 3.1 on all devices and browser combinations apart from Apple products without any issue.

 

When connecting with a non Apple based device to the site, there are zero warnings or errors in the log file.

 

Connecting using an Apple based device fails to load the site correctly as the log file (relevant snippets included below) shows lots of resources failing to load. The weird thing is that this only happens with iOS (even on iOS 12 beta 3) and latest Mac OSX (don’t have older version of Mac OSX to test with).

 

I logged this as a bug on Apple’s site but it is my personal opinion based on past experience that the chances of getting a speedy reply from Apple on this is slim.

 

The error log starts with these long one line errors:

 

/* error log snippet line 1

2018-07-30 09:09:18,741 ERROR [io.undertow] (default task-3078) UT005085: Connection [hidden email] for exchange HttpServerExchange{ GET /edsnext/javax.faces.resource/omnifaces.js.xhtml request {accept=[text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8], accept-language=[en-us], :authority=[edsnext.megchemsa.com:62543], accept-encoding=[gzip, deflate], :path=[/edsnext/javax.faces.resource/omnifaces.js.xhtml?ln=omnifaces&v=3.1], user-agent=[Mozilla/5.0 (iPhone; CPU iPhone OS 12_0 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/12.0 Mobile/15E148 Safari/604.1], :scheme=[https], cookie=[JSESSIONID=U5X9u-A83bccAnpA1XUnEFzmngqI9iDJwuIiU_Qo], :method=[GET], Referer=[https://edsnext.megchemsa.com:62543/edsnext/], upgrade-insecure-requests=[1], Host=[edsnext.megchemsa.com:62543]} response {Expires=[Mon, 30 Jul 2018 09:57:18 GMT], ETag=[W/"5933-1532705069245"], Last-Modified=[Fri, 27 Jul 2018 15:24:29 GMT], Set-Cookie=[JSESSIONID=U5X9u-A83bccAnpA1XUnEFzmngqI9iDJwuIiU_Qo.edsnext; path=/edsnext], Content-Type=[application/javascript], Date=[Mon, 30 Jul 2018 07:09:18 GMT], :status=[200]}} was not closed cleanly, forcibly closing connection

/* end of error log snippet line 1

 

It iterates over all the javax.faces.resources, giving one long error line per resource.

 

Then  it ends with long PrimeFaces warnings starting with:

 

/* start of PrimeFaces warnings

2018-07-30 09:09:21,056 WARNING [javax.enterprise.resource.webcontainer.jsf.application] (default task-3091) JSF1064: Unable to find or serve resource, fa/fontawesome-webfont.eot, from library, primefaces.

2018-07-30 09:09:21,056 WARNING [javax.enterprise.resource.webcontainer.jsf.application] (default task-3084) JSF1064: Unable to find or serve resource, fonts/lato-regular-webfont.svg, from library, primefaces-omega.

2018-07-30 09:09:21,056 WARNING [javax.enterprise.resource.webcontainer.jsf.application] (default task-3082) JSF1064: Unable to find or serve resource, fa/fontawesome-webfont.ttf, from library, primefaces.

2018-07-30 09:09:21,056 WARNING [javax.enterprise.resource.webcontainer.jsf.application] (default task-3100) JSF1064: Unable to find or serve resource, fa/fontawesome-webfont.svg, from library, primefaces.

2018-07-30 09:09:21,056 WARNING [javax.enterprise.resource.webcontainer.jsf.application] (default task-3103) JSF1064: Unable to find or serve resource, fonts/lato-bold-webfont.svg, from library, primefaces-omega.

2018-07-30 09:09:21,056 WARNING [javax.enterprise.resource.webcontainer.jsf.application] (default task-3091) : java.nio.channels.ClosedChannelException

/* end of PrimeFaces warnings

 

This is followed by a stack trace dump from PrimeFaces

 

But like I said previously, this only happens when browsing via iOS or Mac OSX… CentOS 7.5 with Chrome latest and FireFox Developer Edition latest as well as Windows 10 with all browsers works 100% no warnings or errors.

 

Kind regards,

 

George

 

/* POM File

<?xml version="1.0" encoding="UTF-8"?>

<project

        xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"

        xmlns="http://maven.apache.org/POM/4.0.0"

        xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd"

 

 

    <!-- Model Version -->

    <modelVersion>4.0.0</modelVersion>

 

 

    <!-- Application package information -->

    <groupId>com.domain</groupId>

    <artifactId>app</artifactId>

    <version>1.0-SNAPSHOT</version>

    <packaging>war</packaging>

 

 

    <!-- Application final name and URL -->

    <name>${project.artifactId}</name>

    <description>EDSNext</description>

    <url>http://edsnext.headoffice.megchem.co.za</url>

 

 

    <!-- Properties -->

    <properties>

        <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>

        <project.reporting.outputEncoding>UTF-8</project.reporting.outputEncoding>

        <maven.compiler.source>1.8</maven.compiler.source>

        <maven.compiler.target>1.8</maven.compiler.target>

        <failOnMissingWebXml>false</failOnMissingWebXml>

    </properties>

 

 

    <!-- mvn repositories -->

    <repositories>

        <repository>

            <id>JBoss</id>

            <name>public-jboss</name>

            <url>http://repository.jboss.org/nexus/content/groups/public-jboss/</url>

        </repository>

        <repository>

            <id>java.net-maven2-SNAPSHOT-repository</id>

            <name>Java.net SNAPSHOT-Repository for Maven</name>

            <url>https://maven.java.net/content/repositories/snapshots/</url>

            <layout>default</layout>

        </repository>

        <repository>

            <id>java.net-maven2-repository</id>

            <name>Java.net Repository for Maven</name>

            <url>https://maven.java.net/content/repositories/releases/</url>

            <layout>default</layout>

        </repository>

        <repository>

            <id>oss.sonatype.org</id>

            <url>https://oss.sonatype.org/content/repositories/snapshots/</url>

        </repository>

        <repository>

            <id>bintray-snapshot</id>

            <name>libs-snapshot</name>

            <url>http://oss.jfrog.org/artifactory/libs-snapshot</url>

        </repository>

        <repository>

            <snapshots>

                <enabled>false</enabled>

            </snapshots>

            <id>bintray-deluan-maven</id>

            <name>bintray</name>

            <url>http://dl.bintray.com/deluan/maven</url>

        </repository>

    </repositories>

 

 

    <!-- Dependencies -->

    <dependencies>

 

        <!-- Server specific dependencies for WildFly 13 -->

        <dependency>

            <groupId>org.wildfly</groupId>

            <artifactId>wildfly-spec-api</artifactId>

            <version>13.0.0.Final</version>

            <type>pom</type>

            <scope>provided</scope>

       </dependency>

        <dependency>

            <groupId>org.wildfly.bom</groupId>

            <artifactId>wildfly-javaee7-with-tools</artifactId>

            <scope>provided</scope>

            <type>pom</type>

            <version>13.0.0.Final</version>

        </dependency>

        <dependency>

            <groupId>org.hibernate</groupId>

            <artifactId>hibernate-core</artifactId>

            <version>5.3.1.Final</version>

            <scope>provided</scope>

        </dependency>

        <dependency>

            <groupId>org.hibernate.common</groupId>

            <artifactId>hibernate-commons-annotations</artifactId>

            <version>5.0.2.Final</version>

            <scope>provided</scope>

        </dependency>

        <dependency>

            <groupId>org.hibernate.validator</groupId>

            <artifactId>hibernate-validator</artifactId>

            <version>6.0.10.Final</version>

            <scope>provided</scope>

        </dependency>

        <dependency>

            <groupId>javax.persistence</groupId>

            <artifactId>javax.persistence-api</artifactId>

            <version>2.2</version>

        </dependency>

        <dependency>

            <groupId>org.hibernate</groupId>

            <artifactId>hibernate-search-orm</artifactId>

            <version>5.5.8.Final</version>

            <scope>provided</scope>

        </dependency>

        <dependency>

            <groupId>org.jboss.spec.javax.faces</groupId>

            <artifactId>jboss-jsf-api_2.3_spec</artifactId>

            <version>2.3.5.SP1</version>

            <scope>provided</scope>

        </dependency>

        <dependency>

            <groupId>com.sun.faces</groupId>

            <artifactId>jsf-impl</artifactId>

            <version>2.3.5.SP1</version>

            <scope>provided</scope>

        </dependency>

        <dependency>

            <groupId>org.jboss.spec.javax.el</groupId>

            <artifactId>jboss-el-api_3.0_spec</artifactId>

            <version>1.0.11.Final</version>

        </dependency>

        <dependency>

            <groupId>javax.el</groupId>

            <artifactId>javax.el-api</artifactId>

            <version>3.0.1-b06</version>

        </dependency>

 

        <!-- Runtime dependencies.  -->

        <dependency>

            <groupId>net.sf.jasperreports</groupId>

            <artifactId>jasperreports</artifactId>

            <version>6.6.0</version>

        </dependency>

        <dependency>

            <groupId>org.apache.httpcomponents</groupId>

            <artifactId>httpclient</artifactId>

            <version>4.5.6</version>

        </dependency>

        <dependency>

            <groupId>org.apache.httpcomponents</groupId>

            <artifactId>httpcore</artifactId>

            <version>4.4.10</version>

        </dependency>

        <dependency>

            <groupId>org.apache.shiro</groupId>

            <artifactId>shiro-core</artifactId>

            <version>1.4.0</version>

        </dependency>

        <dependency>

            <groupId>org.apache.shiro</groupId>

            <artifactId>shiro-web</artifactId>

            <version>1.4.0</version>

        </dependency>

        <dependency>

            <groupId>org.apache.shiro</groupId>

            <artifactId>shiro-ehcache</artifactId>

            <version>1.4.0</version>

        </dependency>

        <dependency>

            <groupId>org.primefaces</groupId>

            <artifactId>primefaces</artifactId>

            <version>6.2.7</version>

        </dependency>

        <dependency>

            <groupId>org.primefaces.extensions</groupId>

            <artifactId>primefaces-extensions</artifactId>

            <version>6.2.7</version>

        </dependency>

       <dependency>

            <groupId>org.omnifaces</groupId>

            <artifactId>omnifaces</artifactId>

            <version>3.1</version>

        </dependency>

        <dependency>

            <groupId>org.postgresql</groupId>

            <artifactId>postgresql</artifactId>

            <version>42.2.4</version>

        </dependency>

        <dependency>

            <groupId>org.apache.logging.log4j</groupId>

            <artifactId>log4j-api</artifactId>

            <version>2.11.0</version>

        </dependency>

        <dependency>

            <groupId>org.apache.logging.log4j</groupId>

            <artifactId>log4j-core</artifactId>

            <version>2.11.0</version>

        </dependency>

        <dependency>

            <groupId>org.apache.logging.log4j</groupId>

            <artifactId>log4j-web</artifactId>

            <version>2.11.0</version>

        </dependency>

        <dependency>

            <groupId>org.apache.logging.log4j</groupId>

            <artifactId>log4j-slf4j-impl</artifactId>

            <version>2.11.0</version>

        </dependency>

        <dependency>

            <groupId>com.intellij</groupId>

            <artifactId>annotations</artifactId>

            <version>12.0</version>

        </dependency>

        <dependency>

            <groupId>org.apache.commons</groupId>

            <artifactId>commons-text</artifactId>

            <version>1.4</version>

        </dependency>

        <dependency>

            <groupId>org.apache.poi</groupId>

            <artifactId>poi</artifactId>

            <version>3.17</version>

        </dependency>

        <dependency>

            <groupId>org.apache.poi</groupId>

            <artifactId>poi-ooxml</artifactId>

            <version>3.17</version>

        </dependency>

        <dependency>

            <groupId>org.apache.poi</groupId>

            <artifactId>poi-scratchpad</artifactId>

            <version>3.17</version>

        </dependency>

        <dependency>

            <groupId>org.apache.commons</groupId>

            <artifactId>commons-lang3</artifactId>

            <version>3.7</version>

        </dependency>

        <dependency>

            <groupId>commons-fileupload</groupId>

            <artifactId>commons-fileupload</artifactId>

            <version>1.3.3</version>

        </dependency>

        <dependency>

            <groupId>commons-io</groupId>

            <artifactId>commons-io</artifactId>

            <version>2.6</version>

        </dependency>

        <dependency>

            <groupId>org.projectlombok</groupId>

            <artifactId>lombok</artifactId>

            <version>1.18.0</version>

        </dependency>

 

 

        <!-- Test dependencies.       -->

        <dependency>

            <groupId>junit</groupId>

            <artifactId>junit</artifactId>

            <version>4.12</version>

            <scope>test</scope>

        </dependency>

        <dependency>

            <groupId>org.dbunit</groupId>

            <artifactId>dbunit</artifactId>

            <version>2.5.4</version>

            <scope>test</scope>

        </dependency>

        <dependency>

            <groupId>org.jboss.arquillian.junit</groupId>

            <artifactId>arquillian-junit-container</artifactId>

            <version>1.4.0.Final</version>

            <scope>test</scope>

        </dependency>

        <dependency>

            <groupId>org.jboss.arquillian.extension</groupId>

            <artifactId>arquillian-persistence-dbunit</artifactId>

            <version>1.0.0.Alpha7</version>

            <scope>test</scope>

        </dependency>

        <dependency>

            <groupId>org.jboss.shrinkwrap.resolver</groupId>

            <artifactId>shrinkwrap-resolver-impl-maven-archive</artifactId>

            <version>3.1.3</version>

        </dependency>

        <dependency>

            <groupId>org.jboss.arquillian.graphene</groupId>

            <artifactId>graphene-webdriver</artifactId>

            <version>2.3.2</version>

            <type>pom</type>

            <scope>test</scope>

        </dependency>

        <dependency>

            <groupId>com.google.guava</groupId>

            <artifactId>guava</artifactId>

            <version>25.1-jre</version>

            <scope>test</scope>

        </dependency>

 

    </dependencies>

    <!-- End Of Dependencies -->

 

 

    <dependencyManagement>

        <dependencies>

 

            <!-- Test dependencies.   -->

            <dependency>

                <groupId>org.jboss.arquillian</groupId>

                <artifactId>arquillian-bom</artifactId>

                <version>1.4.0.Final</version>

                <type>pom</type>

                <scope>import</scope>

            </dependency>

            <dependency>

                <groupId>org.jboss.arquillian.extension</groupId>

                <artifactId>arquillian-drone-bom</artifactId>

                <version>2.5.1</version>

                <type>pom</type>

                <scope>import</scope>

            </dependency>

        </dependencies>

    </dependencyManagement>

 

 

    <!-- Build settings        -->

    <build>

        <finalName>${project.artifactId}</finalName>

        <plugins>

            <plugin>

                <groupId>org.apache.maven.plugins</groupId>

                <artifactId>maven-enforcer-plugin</artifactId>

                <version>3.0.0-M2</version>

                <executions>

                    <execution>

                        <id>enforce-maven</id>

                        <goals>

                            <goal>enforce</goal>

                        </goals>

                        <configuration>

                            <rules>

                                <requireMavenVersion>

                                    <version>3.3.9</version>

                                </requireMavenVersion>

                            </rules>

                        </configuration>

                    </execution>

                </executions>

            </plugin>

        </plugins>

    </build>

 

</project>

 

/* end of POM file

 

 



Disclaimer

The content of this e-mail message and all attachments thereto (`this message`) does not necessarily reflect the views of MegChem (Pty) Ltd (`MegChem`). Before acting on the contents thereof, the recipient should verify that the originator has the appropriate delegated authority. In the event that this message has not been appropriately authorised in terms of MegChem`s delegation of authority, or in the event of the personal usage of MegChem`s e-mail facility, MegChem will not be liable for the contents of this message.

1. This message may contain information which is confidential, private or privileged in nature and subject to legal privilege. If you are not the intended recipient you may not peruse, use, disseminate, distribute or copy this message or its attachments. Please notify the sender immediately by e-mail, facsimile or telephone and thereafter return and or destroy this original message.

2. Please note that the recipient must scan this message and any attachments for viruses and the like. MegChem accepts no liability, damage or expense resulting directly or indirectly from the access of any message or it`s attachments or the use thereof.

3. MegChem reserves the right to monitor, read, filter, block, delete, use and act upon any incoming or outgoing message or it`s attachments sent or received by the employee, including hyperlinks in such message attachments and files copied or saved, automatically or by the employee on MegChem`s equipment.

4. Please report email abuse / misuse to [hidden email]

This email has been scanned for viruses and malware, and automatically archived by Mimecast SA (Pty) Ltd, an innovator in Software as a Service (SaaS) for business. Mimecast Unified Email Management ™ (UEM) offers email continuity, security, archiving and compliance with all current legislation. To find out more, contact Mimecast.


_______________________________________________
wildfly-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/wildfly-dev