help needed configuring undertow for JBoss EAP 7.1

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

help needed configuring undertow for JBoss EAP 7.1

Marlow, Andrew

Hello everyone,

 

I have been using JBoss 7.1.1 prior to Red Hat creating JBoss EAP. I have also been using Wildfly 9, brought on by Red Hat forking JBoss. Now I am trying to use JBoss EAP 7.1 which contains elements of Wildfly 4. I need help with the configuration please. An EAP change is that instead of subsystem webservices  I have to use undertow. I thought that would not be a problem and found several examples of undertow configuration for versions 3.1 and 4.0. None of them worked (details further below). So I tried version 2.0 which is what I have for my wildfly setup. That didn’t work either. I am at my wits end. I don’t know which version of undertow I should be using and I haven’t the faintest idea what is wrong with my config.

 

Here is my undertow 2.0 config:

 

       <subsystem xmlns="urn:jboss:domain:undertow:2.0">

            <buffer-cache name="default"/>

            <server name="default-server">

                <http-listener name="default" socket-binding="http" redirect-socket="https"/>

                <host name="default-host" alias="localhost">

                    <location name="/" handler="welcome-content"/>

                    <filter-ref name="server-header"/>

                    <filter-ref name="x-powered-by-header"/>

                </host>

            </server>

            <servlet-container name="default">

                <jsp-config/>

                <websockets/>

            </servlet-container>

            <handlers>

                <file name="welcome-content" path="${jboss.home.dir}/welcome-content"/>

            </handlers>

            <filters>

                <response-header name="server-header" header-name="Server" header-value="WildFly/9"/>

                <response-header name="x-powered-by-header" header-name="X-Powered-By" header-value="Undertow/1"/>

            </filters>

        </subsystem>

 

The error I am getting is in server.log:

 

13:52:41,789 ERROR [org.jboss.as.controller] (Controller Boot Thread) WFLYCTL0362: Capabilities required by resource '/subsystem=undertow' are not available:

    org.wildfly.undertow.host.default-server.host; Possible registration points for this capability:

                                /subsystem=undertow/server=*/host=*

13:52:41,790 ERROR [org.jboss.as.controller] (Controller Boot Thread) WFLYCTL0362: Capabilities required by resource '/subsystem=undertow/server=default-server/host=default-host/location=/' are not available:

    org.wildfly.extension.undertow.handler.welcome-content; Possible registration points for this capability:

                                /subsystem=undertow/configuration=handler/file=*

                                /subsystem=undertow/configuration=handler/reverse-proxy=*

13:52:41,805 FATAL [org.jboss.as.server] (Controller Boot Thread) WFLYSRV0056: Server boot has failed in an unrecoverable manner; exiting. See previous messages for details.

 

Andrew Marlow

Consultant developer, Apex

38th Floor, 25 Canada Square,

Canary Wharf, London E14 5LQ

T:  020-8081-2367 / 07966-451-521
E
[hidden email]
FIS | Empowering the Financial World cid:image001.png@01D112FA.C4A77D90cid:image002.png@01D112FA.C4A77D90cid:image003.png@01D112FA.C4A77D90

FIS Apex (UK) Limited * Registered in England and Wales No. 3573008 * Registered Office: 38th floor, 25 Canada Square, London, E14 5LQ, United Kingdom

50_3

 

The information contained in this message is proprietary and/or confidential. If you are not the intended recipient, please: (i) delete the message and all copies; (ii) do not disclose, distribute or use the message in any manner; and (iii) notify the sender immediately. In addition, please be aware that any message addressed to our domain is subject to archiving and review by persons other than the intended recipient. Thank you.
_______________________________________________
wildfly-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/wildfly-dev