master/trunk snapshot issues for CLI and -ds.xml

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

master/trunk snapshot issues for CLI and -ds.xml

Max Rydahl Andersen
Hi,

I wanted to try out AS7 master tonight to test out the new -ds.xml features but I ran into a bunch of issues;
and since it seem to be such basic issues I didn't want to pollute jira upfront.

Is any of this expected currently:

A) jboss-cli --connect just freezes

B) jboss-cli --gui loads UI but NPE's and clicking causes more errors

C) deploying -ds.xml with xadatasource fails after logging a lot of errors/warnings about private api
     "[org.jboss.as.dependency.private] (MSC service thread 1-1) JBAS018567: Deployment "deployment.wonka.war" is using a private module ("<x.y.z>") which may be changed or removed in future versions without notice"

D) deploying -ds.xml without xadatasource seem to work but once app is trying to access logs gets filled with more:
[org.jboss.as.dependency.private] (MSC service thread 1-1) JBAS018567: Deployment "deployment.wonka.war" is using a private module ("org.jboss.iiop-client:main") which may be changed or removed in future versions without notice

E) I can't figure out how to reference it in persistence.xml or resource lookups.
    Using the datasource name, i.e. java:jboss/datasources/DeployedDS does not work in persistence.xml
    Tried both with -ds.xml inside and outside war.
   note, I did nothing special - just a servlet and a CDI bean + persistence.xml; trying to keep it as simple as possible.

should I open lira's or is master considered non-functional in these areas at the moment  ? :)


/max
http://about.me/maxandersen




_______________________________________________
jboss-as7-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/jboss-as7-dev
Reply | Threaded
Open this post in threaded view
|

Re: master/trunk snapshot issues for CLI and -ds.xml

Stuart Douglas

On 31/01/2012, at 12:57 PM, Max Rydahl Andersen wrote:

Hi,

I wanted to try out AS7 master tonight to test out the new -ds.xml features but I ran into a bunch of issues;
and since it seem to be such basic issues I didn't want to pollute jira upfront.

Is any of this expected currently:

A) jboss-cli --connect just freezes

B) jboss-cli --gui loads UI but NPE's and clicking causes more errors

I can't reproduce these. 


C) deploying -ds.xml with xadatasource fails after logging a lot of errors/warnings about private api
    "[org.jboss.as.dependency.private] (MSC service thread 1-1) JBAS018567: Deployment "deployment.wonka.war" is using a private module ("<x.y.z>") which may be changed or removed in future versions without notice"


These warnings are currently happening on every deployment, as our public/private/unsupported modules have not been fully worked out yet. I noticed that the XA datasource deployed fine, but after some time the recovery thread seems to be throwing a NPE. I will investigate. 

D) deploying -ds.xml without xadatasource seem to work but once app is trying to access logs gets filled with more:
[org.jboss.as.dependency.private] (MSC service thread 1-1) JBAS018567: Deployment "deployment.wonka.war" is using a private module ("org.jboss.iiop-client:main") which may be changed or removed in future versions without notice

E) I can't figure out how to reference it in persistence.xml or resource lookups.
   Using the datasource name, i.e. java:jboss/datasources/DeployedDS does not work in persistence.xml
   Tried both with -ds.xml inside and outside war.
  note, I did nothing special - just a servlet and a CDI bean + persistence.xml; trying to keep it as simple as possible.


At the moment I just have a test which looks up and uses the datasource directly, I will add a test that uses JPA and fix any issues that I run into.

Stuart

should I open lira's or is master considered non-functional in these areas at the moment  ? :)


/max
http://about.me/maxandersen




_______________________________________________
jboss-as7-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/jboss-as7-dev


_______________________________________________
jboss-as7-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/jboss-as7-dev
Reply | Threaded
Open this post in threaded view
|

Re: master/trunk snapshot issues for CLI and -ds.xml

Stuart Douglas
In reply to this post by Max Rydahl Andersen
I have worked around the NPE, and added a test for using XML datasources with JPA: https://github.com/jbossas/jboss-as/commit/c0a5a346a157d2d7eb23a40468f40a4c8cb7393d

Stuart



On 31/01/2012, at 12:57 PM, Max Rydahl Andersen wrote:

Hi,

I wanted to try out AS7 master tonight to test out the new -ds.xml features but I ran into a bunch of issues;
and since it seem to be such basic issues I didn't want to pollute jira upfront.

Is any of this expected currently:

A) jboss-cli --connect just freezes

B) jboss-cli --gui loads UI but NPE's and clicking causes more errors

C) deploying -ds.xml with xadatasource fails after logging a lot of errors/warnings about private api
    "[org.jboss.as.dependency.private] (MSC service thread 1-1) JBAS018567: Deployment "deployment.wonka.war" is using a private module ("<x.y.z>") which may be changed or removed in future versions without notice"

D) deploying -ds.xml without xadatasource seem to work but once app is trying to access logs gets filled with more:
[org.jboss.as.dependency.private] (MSC service thread 1-1) JBAS018567: Deployment "deployment.wonka.war" is using a private module ("org.jboss.iiop-client:main") which may be changed or removed in future versions without notice

E) I can't figure out how to reference it in persistence.xml or resource lookups.
   Using the datasource name, i.e. java:jboss/datasources/DeployedDS does not work in persistence.xml
   Tried both with -ds.xml inside and outside war.
  note, I did nothing special - just a servlet and a CDI bean + persistence.xml; trying to keep it as simple as possible.

should I open lira's or is master considered non-functional in these areas at the moment  ? :)


/max
http://about.me/maxandersen




_______________________________________________
jboss-as7-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/jboss-as7-dev


_______________________________________________
jboss-as7-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/jboss-as7-dev
Reply | Threaded
Open this post in threaded view
|

Re: master/trunk snapshot issues for CLI and -ds.xml

Max Rydahl Andersen-2
In reply to this post by Stuart Douglas


> At the moment I just have a test which looks up and uses the datasource directly, I will add a test that uses JPA and fix any issues that I run into.

I tried that too and also tried @resource but failed.

Think it might be me doing it wrong. Got a link for the test or example for this ?
_______________________________________________
jboss-as7-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/jboss-as7-dev
Reply | Threaded
Open this post in threaded view
|

Re: master/trunk snapshot issues for CLI and -ds.xml

Stuart Douglas

On 31/01/2012, at 6:20 PM, Max Andersen wrote:

>
>
>> At the moment I just have a test which looks up and uses the datasource directly, I will add a test that uses JPA and fix any issues that I run into.
>
> I tried that too and also tried @resource but failed.
>
> Think it might be me doing it wrong. Got a link for the test or example for this ?


https://github.com/jbossas/jboss-as/blob/master/testsuite/integration/basic/src/test/java/org/jboss/as/test/integration/deployment/xml/datasource/DeployedXmlJpaDataSourceTestCase.java

and

https://github.com/jbossas/jboss-as/blob/master/testsuite/integration/basic/src/test/java/org/jboss/as/test/integration/deployment/xml/datasource/DeployedXmlDataSourceTestCase.java

Stuart
_______________________________________________
jboss-as7-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/jboss-as7-dev
Reply | Threaded
Open this post in threaded view
|

Re: master/trunk snapshot issues for CLI and -ds.xml

Alexey Loubyansky
In reply to this post by Max Rydahl Andersen
On 01/31/2012 02:57 AM, Max Rydahl Andersen wrote:

> Hi,
>
> I wanted to try out AS7 master tonight to test out the new -ds.xml features but I ran into a bunch of issues;
> and since it seem to be such basic issues I didn't want to pollute jira upfront.
>
> Is any of this expected currently:
>
> A) jboss-cli --connect just freezes
>
> B) jboss-cli --gui loads UI but NPE's and clicking causes more errors

The above is not expected.

Alexey
_______________________________________________
jboss-as7-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/jboss-as7-dev
Reply | Threaded
Open this post in threaded view
|

Re: master/trunk snapshot issues for CLI and -ds.xml

Max Rydahl Andersen
In reply to this post by Max Rydahl Andersen

Reproduced these with snapshot build from yesterday.

> A) jboss-cli --connect just freezes


https://issues.jboss.org/browse/AS7-3537

> B) jboss-cli --gui loads UI but NPE's and clicking causes more errors

https://issues.jboss.org/browse/AS7-3540


/max
http://about.me/maxandersen



_______________________________________________
jboss-as7-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/jboss-as7-dev
Reply | Threaded
Open this post in threaded view
|

Re: master/trunk snapshot issues for CLI and -ds.xml

Alexey Loubyansky
On 02/01/2012 01:44 PM, Max Rydahl Andersen wrote:
>
> Reproduced these with snapshot build from yesterday.
>
>> A) jboss-cli --connect just freezes
 >
>
> https://issues.jboss.org/browse/AS7-3537


That must ModelControllerClient connecting...

>> B) jboss-cli --gui loads UI but NPE's and clicking causes more errors
>
> https://issues.jboss.org/browse/AS7-3540

As I commented on the issue, it assumes the connection has been
established. You can try

jboss-cli --gui -c

If it's really assumed, then I think we should just make it connect
automatically. And if the controller needs to be specified

jboss-cli --gui --controller=host:port

Stan, what do you think?

Thanks,
Alexey

> /max
> http://about.me/maxandersen
>
>
>
> _______________________________________________
> jboss-as7-dev mailing list
> [hidden email]
> https://lists.jboss.org/mailman/listinfo/jboss-as7-dev
_______________________________________________
jboss-as7-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/jboss-as7-dev
Reply | Threaded
Open this post in threaded view
|

Re: master/trunk snapshot issues for CLI and -ds.xml

Max Rydahl Andersen
>> Reproduced these with snapshot build from yesterday.
>>
>>> A) jboss-cli --connect just freezes
>>
>>
>> https://issues.jboss.org/browse/AS7-3537
>
>
> That must ModelControllerClient connecting...
>
>>> B) jboss-cli --gui loads UI but NPE's and clicking causes more errors
>>
>> https://issues.jboss.org/browse/AS7-3540
>
> As I commented on the issue, it assumes the connection has been
> established. You can try
>
> jboss-cli --gui -c
>
> If it's really assumed, then I think we should just make it connect
> automatically. And if the controller needs to be specified
>
> jboss-cli --gui --controller=host:port


either the UI should allow to execute connect or yes jboss-cli --gui should imply -c

btw. now after having the server running for a while I can use jboss-cli to connect just
fine.

weird.

if I restart and connect it freezes again.

/max
http://about.me/maxandersen




_______________________________________________
jboss-as7-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/jboss-as7-dev