unavailable dependencies" => ["jboss.web.\"jboss-as-helloworld.war\" missing [ jboss.web.host.localhost

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

unavailable dependencies" => ["jboss.web.\"jboss-as-helloworld.war\" missing [ jboss.web.host.localhost

Martin Schwartzman

I downloaded and built wolfc-jboss-as-f896114.zip this morning at 8:39am MDT from https://github.com/wolfc/jboss-as/tree/AS7-579. I added Dependencies: org.hornetq.ra in the war's MANIFEST.MF. I started up the server and then deployed my test war. The first time I tried this the server responded to the console with something like: “to deploy war create file jboss-as-helloworld.war.dodeploy”. I did this and my test war deployed. I ran a test where I sent a message to a jms queue and my EJB 3 MDB’s onMessage() was invoked! However, I decided to make a small modification to my war and try again. When I deploy the war the server deploys it without asking for the jboss-as-helloworld.war.dodeploy file and I get the following error:

 

09:59:01,400 ERROR [org.jboss.as.deployment] (DeploymentScanner-threads - 1) {"Composite operation failed and was rolled back. Steps that failed:" => {"Operation step-2" => {"Services with missing/unavailable dependencies" => ["jboss.web.\"jboss-as-helloworld.war\" missing [ jboss.web.host.localhost ]"]}}}

 

Any help will be appreciated.

 

Martin

 

 

 


_______________________________________________
jboss-as7-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/jboss-as7-dev